Pantheon Community

Remote:drush ignoring --yes

Hi all!

I have created a simple script to deploy my code all the way to the live environment, but it seems that de remote:drush command is ignoring the --yes option.

terminus remote:drush site.env cim --yes

The command above is still asking to confirm. What am I doing wrong?

Kind regards,
Frederik

I would think it would be:

terminus drush <SITE.ENV> -y cim

But Iā€™m stuck. Posting to follow if any solutions

Odd!

Here is a link to our Quicksilver example on setting this automatically. Would this work for your use case?

We use slightly different syntax there.
config-import -y

Maybe try and see if this works if you still prefer to run it via terminus
terminus remote:drush site.env config-import -y

1 Like

terminus is stealing your -y flag, rather than passing it along to drush.

You need to feed it the flag -- in order to send the argument to drush. So:
terminus remote:drush site.env config-import -- -y

Longer explanation: shell - What does "--" (double-dash) mean? - Unix & Linux Stack Exchange

2 Likes

Aha! That is what it is. Thanks for dropping some knowledge here!

It works like a charm!

terminus drush $SITE.$ENV cim -- -y

Thank you all for the replies!

1 Like